Data sim L2TP server for ROS

From aa-asterisk.org.uk wiki
Jump to: navigation, search

First make sure you have the L2TP pointed at the WAN IP address of your Routerboard.

Enable L2TP server on a router board

/interface l2tp-server server
set authentication=pap,chap default-profile=default enabled=yes max-mru=1460 max-mtu=1460 mrru=disabled

Set up an L2TP server

/interface l2tp-server
add comment="L2TP Server" disabled=no name="RevDATA SIM" user=<this is the number you will see in L2TP debugging, you can also get it from the log on clueless related to your data sim>

Add a PPP secret

/ppp secret
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 local-address=<IP address on the rb ie 10.10.10.10>\
name=<this is the number you will see in L2TP debugging> \
    password=password profile=default remote-address=<your choice of IP here ie 10.10.10.11> routes="" service=l2tp

The "name" is a number in the format of 4477xxxxxxxx.

You will need to watch the L2TP PPP debug for this, or get it from clueless.

See also